MuscleNerd: JailBreakers & Unlockers Shouldn’t Update To iOS 5.0.1

by monis on November 11, 2011 · 0 comments

Filed in: Cydia,iOS 5,Jailbreaking,News

As per the recent tweet from MuscleNerd, JailBreakers and unlockers should stay away from iOS 5.0.1 until a method is developed to downgrade. Due to the fact that Apple has patched the code signing bug which was found by Charlie Miller and other bug fixes, these things could be responsible for an untethered JailBreak in the future. 

Accidentally, even if you upgrade, there is no method with which you can downgrade to iOS 5.0. Hence, you need to wait until that barrier of SHSH Blobs is fixed again. Later on, these backdoors can be closed using a tweak from Cydia. However, it’s all depend on your choice, that is, whether you want a better battery life or an untethered JailBreak. iOS 5.0 can be JailBroken using the Redsn0w. Though it is tethered in the meantime.

iPhone 4 users who rely on an unlock shouldn’t update to iOS 5.0.1 because ultrasn0w hasn’t been updated yet. Anyhow, tethered JailBreak could be possible on iOS 5.0.1. But we don’t have any official words from hackers. We will keep you updated when more information would come in.

 



You can subscribe to us via RSS or EMAIL